During the unprecedented impact of COVID-19 we have reduced both staff and hours of operation. Because of this, all calls may not be answered. For all technical support related inquires we encourage you to email service@martinlogan.com and sales@martinlogan.com for sales inquiries. Please expect a slightly longer response time than usual. Thank you for your understanding during this time.

Troubleshooting Subwoofers

« Torna a Supporto Home

My MartinLogan subwoofer makes a humming sound and the lights do not switch off. What is going on?

Updated: Aug 24 2018

There may be some minor 60hz hum from somewhere outside of your subwoofer that is causing the sensor to stay turned on. Disconnect the input jacks and see if the light goes out (this may take up to 10 minutes).

If the light goes out, then check to see if the CATV (TV cable) is connected to the processor upstream. The shield of the cable may not be well grounded and as a result it may be passing a tiny bit of voltage down the line to your subwoofer. MartinLogan subwoofers are grounded and thus stray voltages find it easy to take that path (the path of least resistance). To solve this problem ground the CATV by running it through a grounded AC power strip with CATV in/out.

If the cable is not the culprit, the next most likely cause of the hum is that the subwoofer may be on a different electrical circuit from the pre-amp/processor. If their grounds are slightly different from each other they will be equalized by flowing a slight voltage through the subwoofer input interconnect, causing a hum. Again, the voltage may be extremely slight, but could be enough to turn on the circuit as evidenced by the light. The solution will be to plug the subwoofer into the same electrical circuit as the pre-amp/processor.

Prestazioni senza compromessi. Precisione infallibile. Affidabilità costante. Sfruttando la miriade di vantaggi tecnici dei principi elettrostatici per ricreare il suono nella sua forma più vera, questo è ciò di cui parla MartinLogan.